Bug in Data collect version 4 v4.18 (nci) causing "output file absent"?

log in

Advanced search

Message boards : Number crunching : Bug in Data collect version 4 v4.18 (nci) causing "output file absent"?

Author Message
SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2689 - Posted: 13 Mar 2015, 7:55:40 UTC

I just did a Linux upgrade and WUProp failed and WUProp packets kept failing.

<core_client_version>7.2.42</core_client_version>
<![CDATA[
<message>
process exited with code 8 (0x8, -248)
</message>
<stderr_txt>
Process creation (../../projects/wuprop.boinc-af.org/data_collect_v4_418_i686-pc-linux-gnu__nci) failed: Error -1, errno=8
execv: Exec format error

</stderr_txt>
]]>

But now I get "This computer has finished a daily quota of 2 tasks". I'm sure it'll be OK tomorrow, I was just surprised to see there is a quota.

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2691 - Posted: 13 Mar 2015, 8:52:27 UTC
Last modified: 13 Mar 2015, 8:53:19 UTC

Resetting the project has made no difference.

I was getting:

Fri 13 Mar 2015 08:28:56 GMT | WUProp@Home | Output file data_collect_v4_1426193401_1730_0_0 for task data_collect_v4_1426193401_1730_0 absent

Now it is just:
Fri 13 Mar 2015 08:51:42 GMT | WUProp@Home | This computer has finished a daily quota of 1 tasks

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2692 - Posted: 13 Mar 2015, 8:58:25 UTC
Last modified: 13 Mar 2015, 9:04:13 UTC

The problem is a path error in v4.18

Process creation (../../projects/wuprop.boinc-af.org/data_collect_v4_418_i686-pc-linux-gnu__nci) failed: Error -1, errno=8
execv: Exec format error

I have no /projects/wuprop.boinc-af.org/

On this Linux Xubuntu PC it is installed elsewhere:

$ locate wuprop.boinc-af.org
/var/lib/boinc-client/account_wuprop.boinc-af.org.xml
/var/lib/boinc-client/job_log_wuprop.boinc-af.org.txt
/var/lib/boinc-client/master_wuprop.boinc-af.org.xml
/var/lib/boinc-client/sched_reply_wuprop.boinc-af.org.xml
/var/lib/boinc-client/sched_request_wuprop.boinc-af.org.xml
/var/lib/boinc-client/statistics_wuprop.boinc-af.org.xml

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2693 - Posted: 13 Mar 2015, 9:07:38 UTC
Last modified: 13 Mar 2015, 9:13:49 UTC

Ignore me. I'm an idiot.

$ sudo locate wuprop.boinc-af.org
/var/lib/boinc-client/account_wuprop.boinc-af.org.xml
/var/lib/boinc-client/job_log_wuprop.boinc-af.org.txt
/var/lib/boinc-client/master_wuprop.boinc-af.org.xml
/var/lib/boinc-client/sched_reply_wuprop.boinc-af.org.xml
/var/lib/boinc-client/sched_request_wuprop.boinc-af.org.xml
/var/lib/boinc-client/statistics_wuprop.boinc-af.org.xml
/var/lib/boinc-client/notices/archive_wuprop.boinc-af.org_notices.py.xml
/var/lib/boinc-client/notices/feeds_wuprop.boinc-af.org.xml
/var/lib/boinc-client/notices/wuprop.boinc-af.org_notices.py.xml
/var/lib/boinc-client/projects/wuprop.boinc-af.org
/var/lib/boinc-client/projects/wuprop.boinc-af.org/cache

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2694 - Posted: 13 Mar 2015, 9:22:29 UTC
Last modified: 13 Mar 2015, 9:23:16 UTC

However,

$ sudo ls -la /var/lib/boinc-client/projects/wuprop.boinc-af.org
total 44
drwxrwx--x 2 boinc boinc 4096 Mar 13 08:48 .
drwxrwx--x 18 boinc boinc 4096 Jan 13 12:43 ..
-rw-r--r-- 1 boinc boinc 33280 Mar 13 07:26 cache

Shouldn't there be a data_collect_v4_418_i686-pc-linux-gnu__nci in there?

alez [ TSBTs Pirate ]
     
Send message
Joined: 14 Oct 12
Posts: 18
Credit: 1,222,036
RAC: 463
Total hours: 2,766,686
Message 2695 - Posted: 13 Mar 2015, 12:49:23 UTC

All four of my ubuntu 14.04 boxes started throwing this error since the early hours of the morning. One was rebuilt last night the other three have not been touched for a week or two, so doubt the update of Linux has anything to do with it. Windows is unaffected.

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2697 - Posted: 13 Mar 2015, 13:08:00 UTC
Last modified: 13 Mar 2015, 13:15:37 UTC

What do you have in /var/lib/boinc-client/projects/wuprop.boinc-af.org ?

On the PC that is failing, there is just 'cache'.


On another PC that is working (Xubuntu 14.04.2) there is:

# sudo ls -la /var/lib/boinc-client/projects/wuprop.boinc-af.org
total 1696
drwxrwx--x 2 boinc boinc 4096 Mar 13 11:53 .
drwxrwx--x 19 boinc boinc 4096 Jan 11 22:18 ..
-rw-r--r-- 1 boinc boinc 21030 Mar 13 13:03 cache
-rwxr-xr-x 1 boinc boinc 812136 Jul 1 2013 data_collect_v3_3.52_x86_64-pc-linux-gnu__nci
-rw-r--r-- 1 boinc boinc 22029 Mar 13 13:03 data_collect_v4_1426193401_8661_0_0
-rwxr-xr-x 1 boinc boinc 851997 Mar 13 11:53 data_collect_v4_418_x86_64-pc-linux-gnu__nci

so it may only be 32-bit PCs that are failing.

alez [ TSBTs Pirate ]
     
Send message
Joined: 14 Oct 12
Posts: 18
Credit: 1,222,036
RAC: 463
Total hours: 2,766,686
Message 2698 - Posted: 13 Mar 2015, 13:49:55 UTC

I'll have to go and check but for me the 4v4.15 worked perfectly. As soon as I got 4v4.18 units they all fail both on 32 bit and 64 bit versions.
The
Stderr output

<core_client_version>7.4.23</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/wuprop.boinc-af.org/data_collect_v4_418_x86_64-pc-linux-gnu__nci: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

</stderr_txt>
]]>

I guess the app has a broken link to libstdc++.so.6 as that is installed on all my systems.

Donn Pike (USAF Ret)
 
Send message
Joined: 19 Apr 10
Posts: 1
Credit: 465,306
RAC: 332
Total hours: 352,994
Message 2699 - Posted: 13 Mar 2015, 14:09:05 UTC

http://wuprop.boinc-af.org/result.php?resultid=47918633

Getting it also on Slackware 64. Started about 13 Mar 2015, 12:31:19 UTC or so. Above link is the earliest that I can find. WinDoze boxes no problem so far. The are Windoze 8.1.

Donn

computerguy09
 
Send message
Joined: 2 Mar 13
Posts: 3
Credit: 382,734
RAC: 243
Total hours: 587,733
Message 2701 - Posted: 13 Mar 2015, 14:30:03 UTC
Last modified: 13 Mar 2015, 14:31:38 UTC

I started seeing this as of 12 hours or so ago as well on one of my Ubuntu boxes as well as a Fedora 21 machine. Nothing has changed on these boxes in the last week with respect to Linux updates or BOINC changes.

Other clients (mostly Windows) that are running WUProp have not had this issue. Other projects are running successfully on all these boxes.

Mark

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2703 - Posted: 13 Mar 2015, 14:33:56 UTC
Last modified: 13 Mar 2015, 14:36:15 UTC

The Data Collect version 4 application was updated to v4.18 at 6:36 this morning. Link: Applications.

I'm wondering why my Xubuntu box is managing to process a v4.18 packet.

BobCat13
 
Send message
Joined: 6 Apr 10
Posts: 27
Credit: 281,068
RAC: 94
Total hours: 221,876
Message 2705 - Posted: 13 Mar 2015, 14:40:26 UTC - in response to Message 2703.

I'm wondering why my Xubuntu box is managing to process a v4.18 packet.

If it is a 64-bit distro with 32-bit libraries installed it will probably work as the 64-bit executable is really 32-bits.

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2706 - Posted: 13 Mar 2015, 14:42:45 UTC - in response to Message 2705.
Last modified: 13 Mar 2015, 14:43:45 UTC

It is indeed a 64-bit distro with 32-bit libraries installed in addition.

So the 32-bit app is the 64 bit app, and the 64 bit app is the 32 bit app? Oops! :-D

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2707 - Posted: 13 Mar 2015, 14:48:45 UTC

So presumably, if one downloads

http://wuprop.boinc-af.org/download/data_collect_v4_418_i686-pc-linux-gnu__nci

into

/var/lib/boinc-client/projects/wuprop.boinc-af.org

and uses it to overwrite data_collect_v4_418_x86_64-pc-linux-gnu__nc (or vice versa as appropriate), it might work?

BobCat13
 
Send message
Joined: 6 Apr 10
Posts: 27
Credit: 281,068
RAC: 94
Total hours: 221,876
Message 2708 - Posted: 13 Mar 2015, 14:58:43 UTC - in response to Message 2707.
Last modified: 13 Mar 2015, 15:13:33 UTC

So presumably, if one downloads

http://wuprop.boinc-af.org/download/data_collect_v4_418_i686-pc-linux-gnu__nci

into

/var/lib/boinc-client/projects/wuprop.boinc-af.org

and uses it to overwrite data_collect_v4_418_x86_64-pc-linux-gnu__nc (or vice versa as appropriate), it might work?

Not sure. It would have to be renamed to x86_64 after the download/copy and if the project checks for MD5 or CRC32 it may fail as that would not match what is in the client_state.xml file.

I'll give it a try and report back in a few minutes.

Edit: That appears to work. I downloaded the file labeled as 32-bit, renamed it to the 64-bit name, ran ldd and file to check it (everything looked ok) and it has been running for 3 minutes. Will have to wait for 6 hours to see if it finished correctly and verifies.

computerguy09
 
Send message
Joined: 2 Mar 13
Posts: 3
Credit: 382,734
RAC: 243
Total hours: 587,733
Message 2711 - Posted: 13 Mar 2015, 15:37:16 UTC

I was also able to get one of my machines to run a WU by swapping 32/64-bit executables. The other machine has hit it's daily limit and refuses to download another WU, but that will probably reset at 00:00 UTC later today.

My third Linux box continues to run, probably because it has the 32-bit libraries installed.

Mark

LCB001
       
Send message
Joined: 8 Sep 10
Posts: 42
Credit: 1,220,150
RAC: 838
Total hours: 5,203,081
Message 2712 - Posted: 13 Mar 2015, 19:02:36 UTC
Last modified: 13 Mar 2015, 19:03:24 UTC

Looks like the Linux Apps has been updated which seems to have fixed the problem, my Linux vm has gotten a new WU which seems to be working fine.

Now if we could just get the additional badge sets life would be good.

Thanks Sebastien for all your hard work...
____________

SandJ
 
Send message
Joined: 18 Aug 12
Posts: 13
Credit: 125,597
RAC: 51
Total hours: 120,050
Message 2713 - Posted: 13 Mar 2015, 19:29:29 UTC

Woot! Indeed, v4.19 (32 bit) has been running on this PC for 49 minutes. :-)

Where in the commercial software sector could you get this kind of user diagnosis and prompt supplier fix?

alez [ TSBTs Pirate ]
     
Send message
Joined: 14 Oct 12
Posts: 18
Credit: 1,222,036
RAC: 463
Total hours: 2,766,686
Message 2717 - Posted: 13 Mar 2015, 23:58:57 UTC - in response to Message 2713.

Woot! Indeed, v4.19 (32 bit) has been running on this PC for 49 minutes. :-)

Where in the commercial software sector could you get this kind of user diagnosis and prompt supplier fix?


That's why we are called volunteers and not customers :)

Profile [SETI.Germany] Sutaru Tsureku (aka Dirk :-)
 
Send message
Joined: 28 Mar 10
Posts: 21
Credit: 101,173
RAC: 111
Total hours: 314,877
Message 2719 - Posted: 14 Mar 2015, 0:33:24 UTC

The Win app got an update from v4.15 to v4.18.

Someone know why, what's new?

Thanks.
____________


Post to thread

Message boards : Number crunching : Bug in Data collect version 4 v4.18 (nci) causing "output file absent"?


Home | My Account | Message Boards | Results


Copyright © 2017 Sebastien