WUProp Have A New Project URL? 's' added to http.

log in

Advanced search

Message boards : Number crunching : WUProp Have A New Project URL? 's' added to http.

1 · 2 · 3 · Next
Author Message
Profile [SETI.Germany] Sutaru Tsureku (aka Dirk :-)
 
Send message
Joined: 28 Mar 10
Posts: 21
Credit: 101,173
RAC: 111
Total hours: 314,949
Message 4773 - Posted: 5 Mar 2017, 13:24:11 UTC

BOINC informed me about a new notice.

I looked to the messages and found:

WUProp@Home 05.03.17 | 13:29:56 This project is using an old URL. When convenient, remove the project, then add https://wuprop.boinc-af.org/
[UTC +01:00]

Is this correct - or a mistake?

How long the old URL without 's' after http will still work?


Thanks.
____________

HAL9000
 
Avatar
Send message
Joined: 14 Dec 11
Posts: 10
Credit: 4,668,511
RAC: 5,381
Total hours: 6,506,347
Message 4774 - Posted: 5 Mar 2017, 17:34:20 UTC - in response to Message 4773.
Last modified: 5 Mar 2017, 17:34:42 UTC

BOINC informed me about a new notice.

I looked to the messages and found:

WUProp@Home 05.03.17 | 13:29:56 This project is using an old URL. When convenient, remove the project, then add https://wuprop.boinc-af.org/
[UTC +01:00]

Is this correct - or a mistake?

How long the old URL without 's' after http will still work?


Thanks.

I used Notepadd++ to replace all instances of http://wuprop.boinc-af.org/ with https://wuprop.boinc-af.org/ in my BOINC folders instead of rejoining the project.

Profile bcavnaugh
   
Avatar
Send message
Joined: 18 May 14
Posts: 6
Credit: 161,520
RAC: 261
Total hours: 1,395,743
Message 4775 - Posted: 5 Mar 2017, 18:55:05 UTC
Last modified: 5 Mar 2017, 18:55:24 UTC

If users are using BAM! how should they change it?
____________
Crunching@EVGA The Number One Team in the BOINC Community.
Folding@EVGA The Number One Team in the Folding@Home Community.

Profile bcavnaugh
   
Avatar
Send message
Joined: 18 May 14
Posts: 6
Credit: 161,520
RAC: 261
Total hours: 1,395,743
Message 4776 - Posted: 5 Mar 2017, 19:21:07 UTC - in response to Message 4774.

BOINC informed me about a new notice.

I looked to the messages and found:

WUProp@Home 05.03.17 | 13:29:56 This project is using an old URL. When convenient, remove the project, then add https://wuprop.boinc-af.org/
[UTC +01:00]

Is this correct - or a mistake?

How long the old URL without 's' after http will still work?


Thanks.

I used Notepadd++ to replace all instances of http://wuprop.boinc-af.org/ with https://wuprop.boinc-af.org/ in my BOINC folders instead of rejoining the project.


I did this as well and now I have 2 in the Client Software one from BAM! and the changing of the data as you have posted.
____________
Crunching@EVGA The Number One Team in the BOINC Community.
Folding@EVGA The Number One Team in the Folding@Home Community.

Dr Who Fan
   
Avatar
Send message
Joined: 29 Jul 11
Posts: 116
Credit: 352,958
RAC: 271
Total hours: 353,724
Message 4777 - Posted: 5 Mar 2017, 20:31:51 UTC

Seems there is a minor problem with the SERVER STATUS PAGE:

set_cached_data(): can't open ../cache/f2/server_status.php_job_status

____________

Profile DoctorNow
     
Avatar
Send message
Joined: 7 Apr 10
Posts: 105
Credit: 240,435
RAC: 74
Total hours: 499,789
Message 4778 - Posted: 5 Mar 2017, 20:32:28 UTC - in response to Message 4775.

If users are using BAM! how should they change it?

That's up to Willy. When he changes the URL BAM usually does this automatically after the last instance of WU is finished.
____________
Life is Science, and Science rules. To the universe and beyond
Proud member of BOINC@Heidelberg
My BOINC-Stats

Profile bcavnaugh
   
Avatar
Send message
Joined: 18 May 14
Posts: 6
Credit: 161,520
RAC: 261
Total hours: 1,395,743
Message 4779 - Posted: 6 Mar 2017, 5:22:48 UTC - in response to Message 4778.

Thanks, He may have some work to do then, none of the last 6 URL changes have been made on BAM!.
____________
Crunching@EVGA The Number One Team in the BOINC Community.
Folding@EVGA The Number One Team in the Folding@Home Community.

Profile BilBg
Avatar
Send message
Joined: 20 Jun 12
Posts: 63
Credit: 80,489
RAC: 28
Total hours: 95,507
Message 4780 - Posted: 6 Mar 2017, 7:33:11 UTC

 
For old BOINC 6.10.58 (to work with https: on this site)

Go to this page:
https://curl.haxx.se/docs/caextract.html

Get file cacert.pem
Rename cacert.pem to ca-bundle.crt

Copy ca-bundle.crt to BOINC install directory
(you may first Rename the existing ca-bundle.crt to not overwrite it)
 
____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile Pete Broad
   
Send message
Joined: 5 Jul 10
Posts: 22
Credit: 1,918,605
RAC: 4,360
Total hours: 3,612,325
Message 4781 - Posted: 6 Mar 2017, 9:14:01 UTC

I detached but I can't get Native Boinc to attach. It will attach to the old URL though and get work but seeing as it didn't send the last completed work unit I guess I'm stuck. Would have been good to have had a few days notice rather than come to my machines this morning to find them all stuck.

Pete
____________


Profile Rainer Baumeister
 
Send message
Joined: 11 Oct 10
Posts: 3
Credit: 542,132
RAC: 497
Total hours: 985,791
Message 4782 - Posted: 6 Mar 2017, 10:08:13 UTC

Sorry for my bad Language: Old Man.. :-(

3 Win Computer not Problem using the new https.

on Android Fehler -113

my Tablet, 2 Smartphone and 4 Odroiden XU4 not using the https.
http is ok.

Greats Rainer

BobCat13
 
Send message
Joined: 6 Apr 10
Posts: 27
Credit: 281,068
RAC: 94
Total hours: 221,876
Message 4784 - Posted: 7 Mar 2017, 2:26:08 UTC

Well, this is interesting. Neither of my two clients will attach the the https address; one on WinXP (7.6.33), the other on Linux Mint 18.1 (7.6.32). They were first getting "Peer certificate cannot be authenticated with given CA certificate", but that was fixed by BilBg's advice (Thank you). Now when trying to attach to https, Boinc Manager just sits there a few seconds then states it can't connect to server and try later. Here is the Event Log entries from the Linux Mint client:

WUProp@Home 3-6-2017 8:20:48 PM Detaching from project
3-6-2017 8:21:26 PM Fetching configuration file from https://wuprop.boinc-af.org/get_project_config.php
3-6-2017 8:21:29 PM Project communication failed: attempting access to reference site
3-6-2017 8:21:30 PM Internet access OK - project servers may be temporarily down.


I attached back to the http address and it worked and downloaded the exe file, but hangs on the input file as the link to that is https. I have to manually d/l the input file and move it to the project folder for a task to start up. Once the task is finished, it can't upload as the upload server link is https as well. The only way to get the upload to work, is stop the client, edit the client_state.xml file and remove the s from https on the upload link.

Also trying to browse the site using https on FireFox 51.0.1 does not work on either OS.

On WinXP, the following occurs:
Your connection is not secure. The owner of wuprop.boinc-af.org has configured their website improperly. To protect your information from being stolen, FireFox has not connected to this website.

On Linux Mint, a login box pops up with the following:
https://wuprop.boinc-af.org is requesting your username and password. WARNING: Your password will not be sent to the website you are currently visiting!

This is not the regular login to see my account data. It appears to be the login for the administrator of the server.

Profile Eric_Kaiser
 
Send message
Joined: 4 Jun 13
Posts: 14
Credit: 807,761
RAC: 936
Total hours: 2,866,488
Message 4785 - Posted: 7 Mar 2017, 7:59:55 UTC
Last modified: 7 Mar 2017, 8:14:28 UTC

I have only issues with my android devices. Upload and Downloads are stuck.
Resetting the project doesn't help.
On two of my androids I removed the project and added it again with https, but this makes no difference. Either http or https gives me 'Temporarily failed download of data_collect_v4_1488715731_18645: transient HTTP error'

All other devices (Windows/Linux) work without changes being made by me.

Profile Eric_Kaiser
 
Send message
Joined: 4 Jun 13
Posts: 14
Credit: 807,761
RAC: 936
Total hours: 2,866,488
Message 4786 - Posted: 7 Mar 2017, 10:15:36 UTC - in response to Message 4785.
Last modified: 7 Mar 2017, 10:16:24 UTC

Can't edit my last post...

Seems that only android 4.x devices are affected.
My other androids with 5.x and 6.x are running fine.

The 4.x devices are capable to run arm_pie (v5 wu) but they are trying to fetch nci versions (v4 wu).

Bernard
Send message
Joined: 10 Apr 15
Posts: 5
Credit: 99,907
RAC: 158
Total hours: 103,101
Message 4789 - Posted: 8 Mar 2017, 6:41:21 UTC
Last modified: 8 Mar 2017, 6:44:57 UTC

Hi, on my win 7 machine I successfully added the projects via the SSL URL but I get the following

    08/03/2017 08:33:45 | | [error] Can't create HTTP response output file projects/wuprop.boinc-af.org/data_collect_v4_1488715731_61770



and download fails. I have two other Linux machines under WINE and things seem to work with the new URL

EDIT: After detaching and reattaching again WU is downloaded and running.

Profile Eric_Kaiser
 
Send message
Joined: 4 Jun 13
Posts: 14
Credit: 807,761
RAC: 936
Total hours: 2,866,488
Message 4790 - Posted: 8 Mar 2017, 7:44:51 UTC
Last modified: 8 Mar 2017, 7:55:10 UTC

Tested again on one android running 4.x.
Detached the project and tried to add it with https again.
Adding failed with error -184. So added the project again with http only.
The question is why do I receive v4 nci wu?
The v5 version has pie and non_pie available and is running fine on all other androids with android >=5

Here is one result log:


Name data_collect_v4_1488715731_2186_0
Arbeitspaket 66394594
Erstellt 5 Mar 2017, 13:51:27 UTC
Gesendet 5 Mar 2017, 20:59:46 UTC
Ablaufdatum 12 Mar 2017, 20:59:46 UTC
Empfangen 8 Mar 2017, 6:52:45 UTC
Serverstatus Abgeschlossen
Resultat Berechnungsfehler
Clientstatus am herunterladen
Endstatus -186 (0xffffffffffffff46) ERR_RESULT_DOWNLOAD
Computer ID 123591
Laufzeit
CPU Zeit
Prüfungsstatus Ungültig
Punkte 0.00
Device peak FLOPS 0.02 GFLOPS
Anwendungsversion Data collect version 4 v4.20 (nci)
Stderr Ausgabe

<core_client_version>7.0.36</core_client_version>
<![CDATA[
<message>
WU download error: couldn't get input files:
<file_xfer_error>
<file_name>data_collect_v4_1488715731_2186</file_name>
<error_code>-197</error_code>
<error_message>user requested transfer abort</error_message>
</file_xfer_error>

</message>
]]>

Profile skgiven
       
Avatar
Send message
Joined: 7 Sep 10
Posts: 349
Credit: 806,146
RAC: 316
Total hours: 1,455,687
Message 4791 - Posted: 8 Mar 2017, 15:28:58 UTC - in response to Message 4790.

New HTTPS project URL Not working on Ubuntu 16.04 LTS.

Can't download a task.
Getting,
[error] Can't create HTTP response output file projects/wuprop-af.org/data_collect_v4...

Tried to reset project. Didn't work.

Last tasks I returned failed.

Name data_collect_v4_1488715731_50098_0
Workunit 66445385
Created 7 Mar 2017, 9:51:39 UTC
Sent 7 Mar 2017, 18:34:50 UTC
Report deadline 14 Mar 2017, 18:34:50 UTC
Received 8 Mar 2017, 0:36:35 UTC
Server state Over
Outcome Computation error
Client state Compute error
Exit status 0 (0x0)
Computer ID 102076
Run time 6 hours 0 min 5 sec
CPU time 17 sec
Validate state Invalid
Credit 0.00
Device peak FLOPS 0.02 GFLOPS
Application version Data collect version 4 v4.19 (nci)
Peak working set size 6.95 MB
Peak swap size 20.71 MB
Peak disk usage 0.03 MB

Stderr output

<core_client_version>7.6.31</core_client_version>
<![CDATA[
<stderr_txt>
18:34:57 (7468): initialisation
Erreur assignation taille wu
Erreur assignation taille application
18:53:01 (7468): checkpoint failed Operation not permitted
18:54:00 (7468): checkpoint failed Operation not permitted
...
00:35:00 (7468): called boinc_finish

</stderr_txt>
<message>
upload failure: <file_xfer_error>
<file_name>data_collect_v4_1488715731_50098_0_0</file_name>
<error_code>-161 (not found)</error_code>
</file_xfer_error>

</message>
]]>

Profile skgiven
       
Avatar
Send message
Joined: 7 Sep 10
Posts: 349
Credit: 806,146
RAC: 316
Total hours: 1,455,687
Message 4792 - Posted: 8 Mar 2017, 17:32:37 UTC - in response to Message 4791.
Last modified: 8 Mar 2017, 18:13:10 UTC

After detaching (yet again) and re-attaching new tasks downloaded on the Ubuntu 16.04 systems.
However, yesterday I got several server aborts. These tasks from the HTTPS server failed/were server aborted after 1h and appear as (Abandoned):

69267289 66445385 7 Mar 2017, 18:34:50 UTC 8 Mar 2017, 0:36:35 UTC Error while computing 21,605.17 17.79 --- Data collect version 4 v4.19 (nci)
69267273 66445372 7 Mar 2017, 18:33:46 UTC 7 Mar 2017, 18:34:38 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69266107 66444327 7 Mar 2017, 17:34:34 UTC 7 Mar 2017, 18:34:38 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69264811 66433626 7 Mar 2017, 16:33:24 UTC 7 Mar 2017, 17:34:34 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69257482 66436527 7 Mar 2017, 10:33:07 UTC 7 Mar 2017, 16:33:24 UTC Completed and validated 21,601.94 18.51 14.00 Data collect version 4 v4.19 (nci)

69291902 66467579 8 Mar 2017, 15:19:55 UTC 8 Mar 2017, 17:09:00 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69274495 66451851 8 Mar 2017, 0:44:28 UTC 8 Mar 2017, 17:09:00 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69267450 66445531 7 Mar 2017, 18:43:00 UTC 8 Mar 2017, 0:44:28 UTC Error while computing 21,603.96 10.40 --- Data collect version 4 v4.19 (nci)
69266781 66444914 7 Mar 2017, 18:03:37 UTC 7 Mar 2017, 18:42:45 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69266303 66444486 7 Mar 2017, 17:42:38 UTC 7 Mar 2017, 18:42:45 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69259363 66438254 7 Mar 2017, 12:01:33 UTC 7 Mar 2017, 17:42:38 UTC Abandoned 0.00 0.00 --- Data collect version 4 v4.19 (nci)
69252003 66431656 7 Mar 2017, 6:01:16 UTC 7 Mar 2017, 12:01:33 UTC Completed and validated 21,600.83 11.07 14.00 Data collect version 4 v4.19 (nci)


Lets see if these are aborted too...
- Have at least went past 1h...

Profile BilBg
Avatar
Send message
Joined: 20 Jun 12
Posts: 63
Credit: 80,489
RAC: 28
Total hours: 95,507
Message 4793 - Posted: 8 Mar 2017, 20:05:50 UTC - in response to Message 4784.
Last modified: 8 Mar 2017, 20:16:03 UTC

I attached back to the http address and it worked and downloaded the exe file, but hangs on the input file as the link to that is https.

I did what HAL9000 suggested here:
https://wuprop.boinc-af.org/forum_thread.php?id=423&postid=4774#4774

i.e. I never did detach/attach, only (with no BOINC running):
Ctrl+Shift+F in Notepad++



https://postimg.org/image/bkoj3vlcz/

P.S.
Sorry, the image I posted is wrong, the first line "Find what" should begin by http://

 
____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

BobCat13
 
Send message
Joined: 6 Apr 10
Posts: 27
Credit: 281,068
RAC: 94
Total hours: 221,876
Message 4794 - Posted: 8 Mar 2017, 22:53:24 UTC - in response to Message 4793.

I tried HAL9000's advice before any detach/reattach attempts, but all communications using https would timeout.

It ended up being the local DNS cache program I am using. Since http://wuprop.boinc-af.org was already assigned to the IP, when I tried using the https address, the cache program got grumpy and blocked the connection as it used the same IP. I purged the entry in the cache, tried https again and everything worked fine.

Profile Conan
     
Avatar
Send message
Joined: 28 Mar 10
Posts: 289
Credit: 590,943
RAC: 333
Total hours: 1,107,997
Message 4795 - Posted: 9 Mar 2017, 12:15:45 UTC

It would of been nice to hear from the project manager as to what was going to happen.
I have lost over 2 days worth of project hours on 2 computers because they could no longer talk to the project to download work with the downloads just hanging.

We should not have to jump through hoops to get a project working.

Thanks to Hal9000 and BilBg and a lot of copying and editing I have managed to get my two Windows XP computers (running older 6.12.41 clients) toting up hours again.

Conan
____________

1 · 2 · 3 · Next
Post to thread

Message boards : Number crunching : WUProp Have A New Project URL? 's' added to http.


Home | My Account | Message Boards | Results


Copyright © 2017 Sebastien