Samsung S8+ erroring out work units

log in

Advanced search

Message boards : Number crunching : Samsung S8+ erroring out work units

Author Message
vlado101
Send message
Joined: 8 Sep 16
Posts: 4
Credit: 95,370
RAC: 3
Total hours: 157,293
Message 6066 - Posted: 27 Mar 2018, 16:51:08 UTC

Hello everyone,

Is anyone having their work units erroring out while using Android 8.0? I recently got an S8+ and while World Community Grid is working with no issues when I attached WUProp@Home I just kept seeing the work unit with "error while computing" error message.

Any advice is much appreciated.

Thank you

Profile skgiven
       
Avatar
Send message
Joined: 7 Sep 10
Posts: 450
Credit: 912,037
RAC: 290
Total hours: 1,994,786
Message 6068 - Posted: 28 Mar 2018, 7:08:19 UTC - in response to Message 6066.

We can't see your computers or tasks!

Some of my android tasks fail immediately, others run normally. There are two app versions. One works for me, the other does not.

vlado101
Send message
Joined: 8 Sep 16
Posts: 4
Credit: 95,370
RAC: 3
Total hours: 157,293
Message 6069 - Posted: 28 Mar 2018, 15:50:34 UTC - in response to Message 6068.
Last modified: 28 Mar 2018, 15:52:14 UTC

Hi skgiven,

I updated my settings to show the computers under my accounts. I have re-attached the project. I noticed that I am getting "Data collect version 5 v5.03 (android_arm_non_pie)", while my older android phone gets the "Data collect version 5 v5.07 (android_arm_pie)" and completes without errors.

Can you explain the reason as to why the newer android phone seems to be getting what I presume the older version of the Data collect work unit?

The work number is 78713977, 78713950, 78713943.

Thank you

vlado101
Send message
Joined: 8 Sep 16
Posts: 4
Credit: 95,370
RAC: 3
Total hours: 157,293
Message 6070 - Posted: 28 Mar 2018, 15:50:35 UTC - in response to Message 6068.

Hi skgiven,

I updated my settings to show the computers under my accounts. I have re-attached the project. I noticed that I am getting "Data collect version 5 v5.03 (android_arm_non_pie)", while my older android phone gets the "Data collect version 5 v5.07 (android_arm_pie)" and completes without errors.

Can you explain the reason as to why the newer android phone seems to be getting what I presume the older version of the Data collect work unit?

Thank you

mmonnin
   
Send message
Joined: 22 Aug 16
Posts: 155
Credit: 514,305
RAC: 556
Total hours: 1,980,564
Message 6071 - Posted: 28 Mar 2018, 17:46:31 UTC

Older androids run non-PIE and newer run PIE.

Position independent code/executable.
https://en.wikipedia.org/wiki/Position-independent_code

From the article:
Android enabled support for PIEs in Jelly Bean

I don't have any Android 8 devices. Mostly non-PIE devices. My Nexus 9 on Android 5.1.1 can run the PIE app.

It looks like your Android 8 device has a PIE task now. Sometimes it takes a task or two to get the right version.
http://wuprop.boinc-af.org/results.php?hostid=142258

vlado101
Send message
Joined: 8 Sep 16
Posts: 4
Credit: 95,370
RAC: 3
Total hours: 157,293
Message 6073 - Posted: 29 Mar 2018, 20:56:19 UTC - in response to Message 6071.

Hi mmonnin,

Sorry I meant to update this post earlier but you are correct. After downloading two older android type work units my phone then downloaded the correct one so its working without issues.

I erroneously thought that it didn't work after getting tasks being errored out.


Post to thread

Message boards : Number crunching : Samsung S8+ erroring out work units


Home | My Account | Message Boards | Results


Copyright © 2018 Sebastien