Posts by Stephen Uitti

log in
1) Questions and Answers : Unix/Linux : Disk intensive apps (Message 7279)
Posted 31 Jul 2020 by Profile Stephen Uitti
Almost all the BOINC projects i've run have been CPU and/or GPU intensive. I've run into a couple new (to me) projects that appear (vmstat) to be heavily I/O intensive. I have three questions.

1. Does WUProp only count CPU time? (I assume so). So these jobs that take ten hours of wall clock might get 6 hours of credit? I mean, that's fine, i just want to know for sure what is being measured. If it were wall-clock time, that would be different than CPU time. If i could somehow get both, then i'd know how much time i'm waiting on disk, and it wouldn't matter if that was magnets or SSD or how fast the interface is or how many devices. I might be able to convince BOINC of my idea on how to maximize throughput.

2. I'm seeing idle time in the 20-60% range. "top" says it's not swapping. Could i tell BOINC to run 2 cores of CPU intensive apps along with 4 that are more disk intensive? That's 6 apps for a 4 core system. I mean, it might be done with XML edits of some kind. I'll have to find where the Linux install decided to put the BOINC files. 400k files on the root partition. Can't be that hard.

3. This system has 7 GB free, under normal conditions. Could i set up a 6 GB RAM disk and get BOINC to use that? Then everything would count as CPU usage. A startup script would copy the entire BOINC tree to RAM. There wouldn't be any check pointing for power failures, unless i get a UPS system (budget looks OK), and script power down of the mains to copy BOINC data back to spinning magnets before system shut down. Easy, right? Of course UPS systems' aren't advertised with energy listed in watt hours, and instead use VA - which continues to not be a unit of energy, so if you know that your system consumes 260 watts all the time (because you measured it), and you want to know how long you have to shut down, well, there's a black box calculator that doesn't let you plug in 260 watts, so it gives you answers with zero confidence, even if the answer looks like three minutes. Well, the write back to disk should take 2 minutes, maybe. That could be benchmarked. I understand car batteries, maybe i should build my own UPS system from scratch, with like a pi zero, some custom sensors, and relays, and and and what? vacuum tubes? Jeez. Maybe UPS makers have PDFs about the products with real numbers somewhere on the interwebby thing. It would be so much easier if disk intensive apps could be configured to use RAM directly. So far, another 16 GB or 32 GB RAM looks cheaper than a UPS system, as long as the app is checkpointing anyway. This is a question if anyone has done something this crazy. But maybe it's hardly even a comments-accepted thingy.
2) Message boards : Number crunching : Raspberry Pi Data in Results (Message 5903)
Posted 9 Jan 2018 by Profile Stephen Uitti
This might have been discussed. RakeSearch now has an optimized binary that runs on (at least) a pi 3. This makes RakeSearch a pi app, at least. I'm using rakesearch_linux_arm_v7l.tgz for the pi 3 on Raspbian Stretch.

I'm not running a 64 bit pi OS. This should work on such a beast, but i haven't tested it. I also have a pi 2, and pi zeros. I have not yet tested this on these. I'm not sure if they'll work. This app should also work on most droids. There's a 2nd Arm app that might work on a banana pi or higher end droid. I don't have these devices. I don't even know where the droid puts boinc, or how one might install it. But there's a very good chance that it will work. The xml file tells boinc what app to use, and it uses it.

The announcement is here:
http://rake.boincfast.ru/rakesearch/forum_thread.php?id=39

Click on the github link. Click on the rakesearch_linux_arm_v7l.tgz link to download it.

If you haven't already, install boinc:
sudo apt-get install boinc
Use the boinc manager to add rakesearch. Ignore the warning that you may not get units. I get units all the time. The URL is
http://rake.boincfast.ru/rakesearch/
Go to the right folder:
sudo bash
cd /var/lib/boinc-client/projects/rake.boincfast.ru_rakesearch/
Extract the archive:
tar xvf ~/pi/rakesearch_linux_arm_v7l.tgz

Restart (you could probably restart the boinc service instead):
shutdown -r

I see units complete in 5 to 6 hours on the pi 3. Of course, hours are hours, but i'm getting a ton of credit for a pi app. On an x86, i'm getting a ton of credit for an x86 app. The app is 5x to 10x faster than the standard x86 app. In fact, the pi 3 is finishing units in the same time that my (older) x86 used to take. On my older x86, the version i use makes use of sse2 SIMD instructions to speed this app up. Something similar is used on the Arm. It's very, very good work.

The new app is very stable. I personally haven't seen any issues with it. I've only been using it a couple days. Still, that's hundreds of units.

Stephen.
3) Message boards : Number crunching : View last 24hours activity hosts (Message 5529)
Posted 15 Aug 2017 by Profile Stephen Uitti
There's a link just above the table for your apps stats. "View last 24hours activity hosts". I just noticed it. It looks like a handy summary. I have 5 hosts. Left to right: android_6d72742e - A 4 core droid tablet. berfon: a 2 core x86 laptop with GPU, n667745 - a 2 core x86 laptop, pensar - a 4 core x86 desktop with GPU, and pi - a 4 core raspberry pi 2b.

The pi has been running Asteroids@home of late. It's the only machine of the 5 that is running it. However, the page shows that pensar is running Asteroids. And yet, the total hours for the pi (and pensar) are correct. I see it as a cosmetic bug. But who knows, maybe someone else might be confused by their particular setup.

If a fix is going in, it might (or might not) be easy to change the link - "View last 24hours activity hosts" - to "View last 24 hours activity hosts" (note: space between 24 and hours), and even more minor cosmetic issue.

I didn't understand WUProp at all when it came out. Some years later, i signed up, and still didn't understand it. It felt like i was spying on myself or something. Now it's the coolest thing in distributed computing since SETI@Home, in 1999. When i branched out into crunching a bunch of projects under BOINC, i tried to make sure that all projects reached some minimum credit goal. As time went on, this credit goal climbed. Now this same sort of thing can be done with hours.

Stephen.
4) Message boards : Number crunching : Win 7 laptop no longer runs WUProp (Message 4812)
Posted 11 Mar 2017 by Profile Stephen Uitti
That worked!
5) Message boards : Number crunching : Win 7 laptop no longer runs WUProp (Message 4810)
Posted 11 Mar 2017 by Profile Stephen Uitti
Thanks.
6) Message boards : Number crunching : Win 7 laptop no longer runs WUProp (Message 4803)
Posted 10 Mar 2017 by Profile Stephen Uitti
On March 6th or 7th, my Win 7 laptop's WUProp stopped working. The event log said i need to use https instead of http. I reset the project (which worked last year for Collatz for the same problem). Nothing. I deleted WUProp, but it won't let me sign up again, claiming "The server is busy". I've tried daily for a couple days. My other systems - Linux desktops, a pi, and a droid, all are doing fine on WUProp. That leads me to believe it's not a server problem. Has my system been banned? What do i do next? Reinstall BOINC? The system itself has been stable for years and with BOINC, and running WUprop for months.

ID: 122560
Name: n667745 (gotta love Windows host names).
7) Message boards : Number crunching : Raspberry Pi Data in Results (Message 4802)
Posted 10 Mar 2017 by Profile Stephen Uitti
I've got a Pi 2B running Raspbien. It shows up in WUProp.

A couple teams members (Project Blue Book) have pi's and droids. I check their BOINCstats for projects and apps. We've got a Yahoo group and discuss this stuff from time to time. There are a few Pi apps that i've not been able to get to run. I'm considering having more than one SD card to see if different versions work or don't.




Home | My Account | Message Boards | Results


Copyright © 2020 Sebastien